Adding Site from Cloud Backup & Google Fails

I’m using 2 computers: a MacBook pro 16 2019 and iMac 27 2020. Both are running the latest Local 6.3.0+5756. Both are running the latest MacOS Monterey Beta 12.3

I’ve created a cloud backup from the MacBook via Google Drive, which worked fine. I then go to the iMac and create a site from that backup. The site is created without errors, but it cannot be accessed. I get errors such as 502 request error. The “WordPress version” appears as constantly loading.

I’ve tried changing the PHP version, Nginx/Apache, changing Site Domains → Localhost, restarting Local, restarting the computer, tried 3-4 times to create the site from backup, nothing worked.

One of the errors seen:

It seems wp-load.php is missing.

Looking at the folder contents in Local Sites, I think a lot of files are missing: there’s no wp-includes folder and various other files.

I tried copying these missing files and wp-includes manually from the old site (macbook) to the new site. What happens is that I can access the site but I see a WordPress installer that’s asking me to configure WordPress from scratch. If I do, none of my data is there - it’s an empty wp install.

Router log and lightning log:
local-lightning.log (100.1 KB)
error.log (11.2 KB)

Thank you,

Hi @stefsss, thanks for posting! I’m looking into this one on my MacBook Pro, running Monterey 12.2.1.

It looks like that restore stopped midway, or at least missed files. Something that could help me track this down - does this happen consistently? If you create a new site from that same backup again (“MyBackup2”, for example), does wp-load.php or the wp-includes folder come through?

Ideally, I’d like to track down if the files were missed when creating the backup or if they just don’t pull through on creation.

Hi @austinwendt , Thanks for looking into this and for working on Local - awesome product!

I tried running some other tests to help figure out if the files are missing from the backup itself or there’s an issue with site creation.

  1. On the original macbook where the backup was created, I tried using the “Clone site from this backup” option to create a new site from the backup. This worked correctly.
  2. Similarly, on the same macbook I tried clicking on Plus → New Site → Create site from Cloud Backups Addon. This also works - site contents are intact. So I guess the backup itself is fine.

  1. I then switch computers to go on the iMac and do exactly what I did on point (2). This does not work. Wp-load.php and wp-includes/ do not exist in the site.

  2. I made another backup of the same site on the macbook and now there’s an updated backup (v2). On the iMac I tried restoring from this updated backup. Still does not work. Something is different though: now it’s stuck on “Starting up site services…”. No folder for the site has been created in Users/myuser/Local Sites.

  3. I tried logging in and out of the google account on the iMac - same results in tests.

  1. I tried to see if it works when I create a cloud backup on the iMac and and then restore from that backup on the same iMac. Strangely enough…this works. Also works if I restore on the macbook from this backup created on the iMac.
  2. Last test. I go back to the macbook and create another backup, for another site, a very small one with 1 plugin = 50mb total (previous one was larger = 700mb). This time it works to restore it on the iMac.

Not sure what this means - maybe there was indeed an issue with the original backup - or maybe it has to do with its larger size. Is there a way I can delete that backup so I can do it again from scratch? I can’t see it. In Google Drive I can’t find the backup either - is it hidden somehow? I might just have too many folders and files.

1 Like

Bump. It’s June 2022.

Bump. It’s Mid-June 2022

I was checking the forums for a problem I was having with Cloud Backups and it turns out, this is the exact problem I’m having. Almost 7 months later, seems there is still no fix?

Fortunately, the process of manually restoring a cloud backup is well documented and worked flawlessly for me, if somewhat tedious.

Doesn’t mean that this is a bug that should be ignored.

1 Like

I am having the same issue. The google drive backup import doesn’t work for me, tried different computers and it’s not correctly importing the backup. When going to the site it gives a 404 error…

This seems like an issue from a year ago that still hasn’t been solved. Really sad since this is a big feature of local, apart from that I love this program…

I tried running local with admin privileges aswell as disabling anti virus, sadly without succes.
Also note that I am running Win10 21H2

Local logs:

{"localVersion":"6.5.2+6204","osPlatform":"win32","osRelease":"10.0.19044","osArch":"ia32","windowsEdition":"Microsoft Windows 10 Home","linuxEdition":null,"level":"warn","message":"Electron Event ready","timestamp":"2022-12-02T23:02:00.505Z"}
{"localVersion":"6.5.2+6204","osPlatform":"win32","osRelease":"10.0.19044","osArch":"ia32","windowsEdition":"Microsoft Windows 10 Home","linuxEdition":null,"level":"warn","message":"Electron Event ready","timestamp":"2022-12-02T23:02:22.244Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:02:44.379731Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe (mysqld 8.0.16) starting as process 12804","timestamp":"2022-12-02T23:02:45.670Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:02:44.381018Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.","timestamp":"2022-12-02T23:02:45.670Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:02:45.652824Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.","timestamp":"2022-12-02T23:02:45.671Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:02:45.671791Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe: ready for connections. Version: '8.0.16'  socket: ''  port: 10005  MySQL Community Server - GPL.","timestamp":"2022-12-02T23:02:45.671Z"}
{"thread":"main","class":"BackupAddonRestoreService","errno":-4048,"code":"EPERM","syscall":"lstat","path":"C:\\Users\\lukas\\Local Sites\\bobthecatbackup\\logs\\nginx\\error.log","level":"error","stack":"Error: EPERM: operation not permitted, lstat 'C:\\Users\\lukas\\Local Sites\\bobthecatbackup\\logs\\nginx\\error.log'","message":"EPERM: operation not permitted, lstat 'C:\\Users\\lukas\\Local Sites\\bobthecatbackup\\logs\\nginx\\error.log'","timestamp":"2022-12-02T23:04:39.984Z"}
{"thread":"main","class":"BackupAddonRestoreService","message":"{\"message\":\"Error: EPERM: operation not permitted, lstat 'C:\\\\Users\\\\lukas\\\\Local Sites\\\\bobthecatbackup\\\\logs\\\\nginx\\\\error.log'\",\"type\":\"error.platform.restoreBackup.movingSiteFromTmpDir:invocation[0]\"}","level":"error","timestamp":"2022-12-02T23:04:40.573Z"}
{"thread":"main","reason":{},"p":{},"eventId":"2d6c84c2d80142bcbcc0fa17dac8c5ca","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-12-02T23:04:40.575Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:04:40.458304Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe (mysqld 8.0.16) starting as process 3024","timestamp":"2022-12-02T23:04:41.909Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:04:40.459715Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.","timestamp":"2022-12-02T23:04:41.909Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:04:41.143301Z 0 [System] [MY-010229] [Server] Starting crash recovery...","timestamp":"2022-12-02T23:04:41.909Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:04:41.147862Z 0 [System] [MY-010232] [Server] Crash recovery finished.","timestamp":"2022-12-02T23:04:41.910Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:04:41.890380Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.","timestamp":"2022-12-02T23:04:41.910Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-12-02T23:04:41.909781Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe: ready for connections. Version: '8.0.16'  socket: ''  port: 10005  MySQL Community Server - GPL.","timestamp":"2022-12-02T23:04:41.910Z"}

Similar issue as described before, sadly no one posted a solution:

Hello all, :wave:

Thank you for writing in about Cloud Backups - I wanted to provide a quick update from the Local Engineering team.

We have several tickets on deck regarding tuning up the functionality of Cloud Backups that should be addressed early next year.

Stay tuned, and thank you for being a part of the Local community!


I’m having the exact same issue. Works perfectly (import and export using Google Drive) on M1 MacBook Air, but the same behaviour described previously is happening on my Windows machines (Wordpress version constantly loading and never appearing, site not accessible). Such a useful platform, but utility is definitely curtailed when I can’t seamlessly use it on all my devices.

I ended up installing a Linux instance of Local using WSLg. I only needed to change the router mode to localhost and it works great. Windows definitely seems to be the culprit for my problems.

1 Like

Hello @dexcain -

Thank you for that feedback, I’ll be sure to pass off this info to the Local engineering team (Windows being the culprit for your problems).

We appreciate you!


I’ve had the same problem since it was released, but have never taken the time to try troubleshooting it or narrowing down the symptoms. FWIW, I’ve been creating backups using dropbox on my macOS laptop and trying to restore them on a Windows 11 (build 25941) PC.

There also seems to be multiple reports of similar issues, with Windows seemingly being the culprit. The LocalWP said that they’d be looking into it, but I still haven’t seen a resolution.

Manually restoring the files per the LocalWP article works, but it is a massive PITA and it doesn’t let me use the same restic repository as the source site.

Below are some potentially relevant lines from my local-lightening.log file

{"thread":"main","class":"BackupAddonRestoreService","errno":-4048,"code":"EPERM","syscall":"lstat","path":"C:\\Users\\lowea\\Local Sites\\twentytwentythree-demo-backup\\logs\\nginx\\error.log","level":"error","stack":"Error: EPERM: operation not permitted, lstat 'C:\\Users\\lowea\\Local Sites\\twentytwentythree-demo-backup\\logs\\nginx\\error.log'","message":"EPERM: operation not permitted, lstat 'C:\\Users\\lowea\\Local Sites\\twentytwentythree-demo-backup\\logs\\nginx\\error.log'","timestamp":"2023-09-05T13:03:40.636Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2023-09-05T13:03:41.578531Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe (mysqld 8.0.16) starting as process 11040","timestamp":"2023-09-05T13:03:42.948Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2023-09-05T13:03:41.579495Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.","timestamp":"2023-09-05T13:03:42.948Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2023-09-05T13:03:42.204256Z 0 [System] [MY-010229] [Server] Starting crash recovery...","timestamp":"2023-09-05T13:03:42.948Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2023-09-05T13:03:42.208080Z 0 [System] [MY-010232] [Server] Crash recovery finished.","timestamp":"2023-09-05T13:03:42.948Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2023-09-05T13:03:42.920177Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.","timestamp":"2023-09-05T13:03:42.948Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2023-09-05T13:03:42.948431Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe: ready for connections. Version: '8.0.16'  socket: ''  port: 10145  MySQL Community Server - GPL.","timestamp":"2023-09-05T13:03:42.949Z"}
{"thread":"main","class":"BackupAddonRestoreService","message":"{\"message\":\"Error: EPERM: operation not permitted, lstat 'C:\\\\Users\\\\lowea\\\\Local Sites\\\\twentytwentythree-demo-backup\\\\logs\\\\nginx\\\\error.log'\",\"type\":\"error.platform.restoreBackup.movingSiteFromTmpDir:invocation[0]\"}","level":"error","timestamp":"2023-09-05T13:03:43.876Z"}
{"thread":"main","reason":{},"p":{},"eventId":"c2bf22cced4b4e2c9b54e1fdc1429284","level":"warn","message":"Unhandled Rejection.","timestamp":"2023-09-05T13:03:43.880Z"}


The EPERM errors in your log look like maybe Local is running into a security blocker. You could check this to start:


Are you going from Windows to Windows? Or different OSes?

Hey @Nick-B, Thanks for the reply.

The hosts file is not read-only and I tested it with Windows Defender disabled. Editing the hosts file does trigger a UAC elevation prompt, so maybe that’s what the log file is indicating.

I’ve tried it with a macOS source → Windows Destination and with a Windows Source → Windows Destination. I don’t have my laptop handy at the moment to test macOS → macOS.

The big issue that I see is that the files never get restored to the site. This happens when I run local normally or as Administrator. The folder structure it creates is as follows (note the missing app/public directory and contents):

    - app
        - sql
            - local.sql
    - conf
        - mysql
            - my.cnf.hbs
        - nginx
            - includes
                - gzip.conf.hbs
                - mime-types.conf.hbs
                - restrictions.conf.hbs
                - wordpress-multi.conf.hbs
                - wordpress-single.conf.hbs
            - nginx.conf.hbs
            - site.conf.hbs
        - php
            - php-fpm.d
                - www.conf.hbs
            - php.ini.hbs
            - php-fpm.conf.hbs
    - logs
        - nginx
            - error.log

Hello all! An update to Cloud Backups has been released that includes a couple of bug fixes:

  • Restoring from a backup for Windows users

  • Multiple sites being created from the same backup

The above issues should now be resolved so feel free to update and report back to us if you have any questions or further hiccups!


This topic was automatically closed after 730 days. New replies are no longer allowed.